Welcome, Guest. Please login or register. Did you miss your activation email?

* CLIENTS SECTION RULES

This section is for CLIENTS (Full SMOD Releases) ONLY.
You may create a new topic in this area to release your SMOD Mod. If you post anything off-topic here you will be temp-banned. This is so you don't hassle the moderators too much, they are volunteers.

If you need help with a mod, post a reply in its thread. Do not start a new topic for help here!

Please use good taste when releasing your mod. Adding 30 custom weapons from the release archive into SMOD Redux and then releasing as your own mod will be frowned upon.  :(

Author Topic: SMOD Standalone 0.65  (Read 186834 times)

0 Members and 1 Guest are viewing this topic.

Offline Cosmonaut

  • *
  • +1% chance to make useful post
  • Cosmonaut has no influence.
Re: SMOD Standalone 0.30
« Reply #30 on: April 02, 2014, 01:17:19 AM »
Hi, new here.

I came across SMOD standalone while trying to get back the mod I used to play back when it worked regularly. I was very pleased to say the least! You've done a great job here.

However, when trying to play SMOD: Tactical version 1.0, or any version for that matter, I get missing textures / models and things of that sort. I tried to fix the problem alone, but nothing I did worked. Everything that uses a Counter-Strike: Source model, sound, or texture is missing and appears as an error. I tried mounting cs:s in the gameinfo.txt, but I either did it wrong or it did not work.

the gameinfo.txt
Code: [Select]
"GameInfo"
{
game "SMOD: Tactical Version 1.0"
title "SMOD: Tactical Version 1.0"
type "singleplayer_only"
 "developer" "The SMOD Author, Phatcat, Onemanshow and others"
 "developer_url" "http://www.smod-tactical.com"
"icon" "smodicon"

FileSystem
{
SteamAppId 220 // This will mount all the GCFs we need (240=CS:S, 220=HL2).
ToolsAppId 211 // Tools will load this (ie: source SDK caches) to get things like materials\debug, materials\editor, etc.

SearchPaths
{
Game |gameinfo_path|.
game "|gameinfo_path|..\SDKBase"
game "|gameinfo_path|..\..\..\common\Half-Life 2\hl2"

game "|gameinfo_path|..\..\..\common\Counter-Strike Source\cstrike"
Game "|gameinfo_path|..\CSSBase"
}
}
}
Tried changing the SteamappID to 240, didn't work. Note that it was originally 215, though I have no idea what that refers to.
I almost started to manually insert models, textures, etc. of anything missing, but I stopped myself when I realized I didn't know what I was doing.

Please, bear with me as I am very unfamiliar with modifying sourcemods, and it is a blessing that I've even made it this far, lol. So if anyone is willing to help me, it's much appreciated!

I'd also like to thank Vedad1944 for providing the fix to another problem I had.

Offline minmi96

  • *
  • *
  • +7% chance to make useful post
  • minmi96 is working their way up.minmi96 is working their way up.minmi96 is working their way up.
    • www.titsassesanddicks.cum
Re: SMOD Standalone 0.30
« Reply #31 on: April 02, 2014, 08:01:02 AM »
Hey, try this, go to the scripts folder and then addcontents.txt
It should say:
Code: [Select]
"Additional contents list"
{
"Contents" {
"hl2" {
"path" "hl2"
"id" "220"
}
// "HL2MP" {
// "path" "hl2mp"
// "id" "320"
// }
// "HL1:S" {
// "path" "hl1"
// "id" "280"
// }
// "CS:S" {
// "path" "cstrike"
// "id" "240"
// }
// "DOD:S" {
// "path" "dod"
// "id" "300"
// }
//        "Episode 1"{
//        "path" "episodic"
//          "id"   "380"
// }
// "LostCoast" {
// "path" "lostcoast"
// "id" "340"
// }
}
}

Set it to:

Code: [Select]
"Additional contents list"
{
// "Contents" {
// "hl2" {
// "path" "hl2"
// "id" "220"
// }
// "HL2MP" {
// "path" "hl2mp"
// "id" "320"
// }
// "HL1:S" {
// "path" "hl1"
// "id" "280"
// }
// "CS:S" {
// "path" "cstrike"
// "id" "240"
// }
// "DOD:S" {
// "path" "dod"
// "id" "300"
// }
//        "Episode 1"{
//        "path" "episodic"
//          "id"   "380"
// }
// "LostCoast" {
// "path" "lostcoast"
// "id" "340"
// }
}
}

Launched Survivor 2020 without a hitch.
-snip-
OK I tried it and it still keeps crashing...
EDIT: I Saw an error this time and it said something about missing background image I think.
« Last Edit: April 02, 2014, 09:02:13 AM by minmi96 »


Let's Get Some Pussy Tonight.

Offline Fidchell

  • *
  • *
  • +4% chance to make useful post
  • Fidchell has no influence.
Re: SMOD Standalone 0.30
« Reply #32 on: April 02, 2014, 04:43:54 PM »
Hi, new here.

I came across SMOD standalone while trying to get back the mod I used to play back when it worked regularly. I was very pleased to say the least! You've done a great job here.

However, when trying to play SMOD: Tactical version 1.0, or any version for that matter, I get missing textures / models and things of that sort. I tried to fix the problem alone, but nothing I did worked. Everything that uses a Counter-Strike: Source model, sound, or texture is missing and appears as an error. I tried mounting cs:s in the gameinfo.txt, but I either did it wrong or it did not work.

the gameinfo.txt

Tried changing the SteamappID to 240, didn't work. Note that it was originally 215, though I have no idea what that refers to.
I almost started to manually insert models, textures, etc. of anything missing, but I stopped myself when I realized I didn't know what I was doing.

Please, bear with me as I am very unfamiliar with modifying sourcemods, and it is a blessing that I've even made it this far, lol. So if anyone is willing to help me, it's much appreciated!

I'd also like to thank Vedad1944 for providing the fix to another problem I had.

You do have the contents of CSS under your CSSbase folder, right? Here's a tutorial for extracting the files. http://bsnooch.com/forums/index.php?topic=1270.0

Hey, try this, go to the scripts folder and then addcontents.txt
It should say:

Launched Survivor 2020 without a hitch.
-snip-
OK I tried it and it still keeps crashing...
EDIT: I Saw an error this time and it said something about missing background image I think.

Here's my addcontents.txt

Code: [Select]
"Additional contents list"
{
"Contents" {
"CS:S" { "path" "c:\SMOD\CSS\cstrike\" }

"HL2" { "path" "c:\SMOD\HL2\hl2" }

"HL2MP" { "path" "c:\SMOD\HL2DM\hl2mp\" }
}

By looking at the paths, you should have a clue of where the source files are located. I didn't have to do any of the CSSbase stuff with this setup, and everything works perfectly. There should be a tutorial floating around for this.
« Last Edit: April 02, 2014, 04:47:21 PM by Fidchell »

Offline Cosmonaut

  • *
  • +1% chance to make useful post
  • Cosmonaut has no influence.
Re: SMOD Standalone 0.30
« Reply #33 on: April 02, 2014, 08:45:55 PM »

You do have the contents of CSS under your CSSbase folder, right? Here's a tutorial for extracting the files. http://bsnooch.com/forums/index.php?topic=1270.0

Hey, try this, go to the scripts folder and then addcontents.txt
It should say:

Launched Survivor 2020 without a hitch.
-snip-
OK I tried it and it still keeps crashing...
EDIT: I Saw an error this time and it said something about missing background image I think.

Here's my addcontents.txt

Code: [Select]
"Additional contents list"
{
"Contents" {
"CS:S" { "path" "c:\SMOD\CSS\cstrike\" }

"HL2" { "path" "c:\SMOD\HL2\hl2" }

"HL2MP" { "path" "c:\SMOD\HL2DM\hl2mp\" }
}

By looking at the paths, you should have a clue of where the source files are located. I didn't have to do any of the CSSbase stuff with this setup, and everything works perfectly. There should be a tutorial floating around for this.

Thanks for the reply! I will try your method out and see if it works.

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: SMOD Standalone 0.30
« Reply #34 on: April 02, 2014, 09:02:12 PM »
I'm having an issue here, when I start it up it gives me a black screen but  still hear the menu music. Any ideas?

Offline minmi96

  • *
  • *
  • +7% chance to make useful post
  • minmi96 is working their way up.minmi96 is working their way up.minmi96 is working their way up.
    • www.titsassesanddicks.cum
Re: SMOD Standalone 0.30
« Reply #35 on: April 03, 2014, 05:09:12 AM »
I'm having an issue here, when I start it up it gives me a black screen but  still hear the menu music. Any ideas?
Same here, did you use Fidchells fix by any chance?


Let's Get Some Pussy Tonight.

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: SMOD Standalone 0.30
« Reply #36 on: April 03, 2014, 01:19:56 PM »
I'm having an issue here, when I start it up it gives me a black screen but  still hear the menu music. Any ideas?
Same here, did you use Fidchells fix by any chance?
Nope. I will see what I can do.

Offline Vedad1944

  • *
  • +2% chance to make useful post
  • Vedad1944 has no influence.
Re: SMOD Standalone 0.30
« Reply #37 on: April 03, 2014, 07:17:32 PM »
For those with the black screen, check your SDKbase folder. It should be like 2.5 GB, if not reinstall OR extract HL2 yourself, might fix the problem :)

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: SMOD Standalone 0.30
« Reply #38 on: April 04, 2014, 05:53:22 PM »
UPDATE: Ok guys I checked again and it was my bad, my SDK 2006 wasn't on the latest version, I guess that's the problem, downloading right now, then I will reinstall.

EDIT: Works charming now, thx for this Pepsi! This also gave me an motivation boost...I'm currently working on a bigger project...
« Last Edit: April 04, 2014, 07:19:58 PM by Counter-Life™ »

Offline TwoTails

  • *
  • +1% chance to make useful post
  • TwoTails has no influence.
Re: SMOD Standalone 0.30
« Reply #39 on: April 04, 2014, 06:24:11 PM »
Hi, when I try running this I just get this error:



Can someone tell me why? Thanks in advance.

Offline slashaXD

  • *
  • +1% chance to make useful post
  • slashaXD has no influence.
Re: SMOD Standalone 0.30
« Reply #40 on: April 05, 2014, 12:51:42 AM »
This is probably a really dumb question but when I try to launch my mod it tells me "Extra App ID set to 300, but no SteamAppId" Does anyone know how to solve this?

Offline Comrade

  • *
  • *
  • +11% chance to make useful post
  • Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...
Re: SMOD Standalone 0.30
« Reply #41 on: April 05, 2014, 08:30:20 AM »
This is probably a really dumb question but when I try to launch my mod it tells me "Extra App ID set to 300, but no SteamAppId" Does anyone know how to solve this?

Not a stupid question at all. I've had this problem when I tried to launch SMOD:Realism. All you have to do is go to the scripts folder of your SMOD, and then find a file called "addcontents.txt" and then comment out the entire file, or just erase every entry in there.

Offline slashaXD

  • *
  • +1% chance to make useful post
  • slashaXD has no influence.
Re: SMOD Standalone 0.30
« Reply #42 on: April 05, 2014, 08:07:47 PM »
Thanks Antivirus! But now I'm getting a black screen but the music is playing and I hear the button sounds when I move my mouse. It's a problem similar to counter lifes problem, so I tried updating everything but everything was already up to date and I'm still getting the same problem. Anyone willing to help? :-\

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: SMOD Standalone 0.30
« Reply #43 on: April 06, 2014, 11:17:13 AM »
When I try to start my own SMOD mod it gives me "Extra AppID set to 220, but no SteamAppID"

And yes, I setted the ID to 220.

Any help? I have been following the insctructions.
« Last Edit: April 06, 2014, 11:21:26 AM by Counter-Life™ »

Offline Comrade

  • *
  • *
  • +11% chance to make useful post
  • Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...
Re: SMOD Standalone 0.30
« Reply #44 on: April 06, 2014, 11:47:35 AM »
When I try to start my own SMOD mod it gives me "Extra AppID set to 220, but no SteamAppID"

And yes, I setted the ID to 220.

Any help? I have been following the insctructions.

go to scripts/addcontents.txt and delete everything