Welcome, Guest. Please login or register. Did you miss your activation email?

* TUTORIAL SECTION RULES

This section is for SMOD TUTORIALS & GUIDES ONLY.
You may create a new topic in the appropriate area to share your tutorial. If you post anything off-topic here you will be temp-banned. This is so we don't hassle the moderators too much, they are volunteers.

If you need help with a tutorial, post a reply in its thread . Do not start a new topic for help here!

Author Topic: [Tutorial] Make SMOD dosent crash so often/LAA  (Read 16949 times)

0 Members and 1 Guest are viewing this topic.

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
[Tutorial] Make SMOD dosent crash so often/LAA
« on: February 09, 2013, 03:11:31 PM »
Hello BSNOOCH Community and SMODDERS, I will show you here one of the most important tutorials for SMOD.

First I want to thank OneManShow for giving me the idea for this.

This tutorial is meant for avanced SMOD users who have created their own SMOD Mini-mods, packed their mods with more content and who have problems with constant crashes now.

So lets get started!

Step 1: Move to your SteamApps/*accountname*/Source sdk base folder, and copy the hl2.exe u find in there to another folder.

Step 2: Download the tool from this site: http://www.techpowerup.com/forums/showthread.php?t=112556 (scoll down a bit and download it)

Step 3: After downloading, make sure u close Steam!

Step 4: Open the tool, and browse to ur hl2.exe in your source sdk base folder(NOT THE ONE THAT U COPIED)

Step 5: check the LAA(Large Address Aware) box and save the settings.

Step 6: Open the properties of the hl2.exe, it should say it was changed a moment ago and check the box that says "read-only"(might be different Im german so I dont know what it says in english, this is needed to be checked, else Steam will replace the .exe with the original one again) and save the settings. After this is done, u can open Steam again.

Step 7: Make sure the backuped hl2.exe is in a save place.

Step 8: Open your Steam, click right on your SMOD mod and click on "properties", then click on "Set launch options..." and add these: -nolocalcopy -hushsteam
(fixes the .exe dosent get replaced by Steam, Thanks to OneManShow for finding this!)

Step 9: Open your SMOD, test if it crashes, see that it dosent and ENJOY!

NOTES:- I dont take any credit for this tool, it wasnt made by me!
            - As long u have the changed hl2.exe in this folder, u should not play Multiplayer mods wich are based on 2006 Source, it might conflict with VAC or something.
            - Only do this fix, if you have atleast 3GB RAM!
           (OMS Note) - If you run any other mods that use the Source 2006 engine, Apply Step 8 to those before you run them. otherwise Steam will overwrite the .exe.

I tested this myself and it worked! I hope this will end the crash problems for everyone!

So how does this work, and why does SMOD crashes so often?

I will take a quote from OneManShow here:

Quote
The problem is not specifically with SMOD, but with the Source 2006 engine. Regardless of your actual, available memory on your comp, Source 2006 only handles a small amount of it. If the memory used during a map load exceeds the engine's limit, It'll crash during said map load.

There's not many ways around this annoyingly low memory limit. The only real fix would be to make the Source 2006 .exe file Large Address Aware so it can use more memory. I can personally confirm that it works. I ran a heavily modified SMOD with Fakefactory's environment textures through it with no problem when it used to crash every other map load. But the problem with that is that Steam will replace the modified .exe file even in Offline Mode. It's sad because I'm pretty sure that it didn't do that until they did an update to the SDK last year. :(

Dont forget to save the original .exe!

UPDATE: I noticed that sometimes(very rarely) Steam still replaces the .exe, u better copy ur fixed hl2.exe and overwrite the new hl2.exe file with it, if theres no .exe in the source sdk base folder, just put the fixed .exe in, it makes no difference, the fix will work then again.

UPDATE 2: OneManShow found a REAL way how Steam won't replace the .exe, simply set the whole folder to read only! It will still sometimes say "The game is currently unaviable". but it won't replace the .exe anymore!

« Last Edit: October 09, 2013, 07:27:36 PM by Counter-Life™ »

Offline Xamp

  • *
  • +2% chance to make useful post
  • Xamp has no influence.
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #1 on: February 09, 2013, 04:05:23 PM »
Even if you haven't overpacked your SMOD, it runs like butter now, a lot better then befor, epic job CL, you deserve a medal.


On wall duty again

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #2 on: February 09, 2013, 04:14:33 PM »
Even if you haven't overpacked your SMOD, it runs like butter now, a lot better then befor, epic job CL, you deserve a medal.

I also noticed that, I get like 5 to 10 FPS more than before! And thx, I never would have tried it without OMS tough.
« Last Edit: February 09, 2013, 04:19:37 PM by Counter-Life™ »

Offline Xamp

  • *
  • +2% chance to make useful post
  • Xamp has no influence.
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #3 on: February 09, 2013, 04:25:53 PM »
Deep respect to OMS, thank you sir.


On wall duty again

Offline BIZ

  • 32-Bit Hobo
  • *
  • *
  • +0% chance to make useful post
  • BIZ hides in shadows.
    • BSNOOCH.COM
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #4 on: February 09, 2013, 04:58:59 PM »
Deep respect to OMS, thank you sir.

go here and give him some +rep if it was useful.

Offline Onemanshow

  • JuanMan
  • *
  • *
  • +67% chance to make useful post
  • Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #5 on: February 09, 2013, 05:20:08 PM »
Just a FYI, Steam will replace the modified .exe with its own after a number of start-ups (which is why I didn't post this myself). You'll know when it happens when it says "This game is not available". You should be able to repeat the steps in this tutorial to reapply the LAA fix when this happens, although Steam won't generate a new .exe file until the next time you start SMOD or any other mod using Source 2006.

EDIT: VVV Just start up SMOD again and it should generate a new .exe file.
« Last Edit: February 09, 2013, 07:28:24 PM by Onemanshow »

Offline Fidchell

  • *
  • *
  • +4% chance to make useful post
  • Fidchell has no influence.
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #6 on: February 09, 2013, 05:37:10 PM »
I don't have a HL2.exe in my source sdk base folder. :(

Offline Xamp

  • *
  • +2% chance to make useful post
  • Xamp has no influence.
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #7 on: February 09, 2013, 05:52:08 PM »
go here and give him some +rep if it was useful.

Rep has been given, thanks for the advice.


On wall duty again

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #8 on: February 09, 2013, 08:05:17 PM »
Just a FYI, Steam will replace the modified .exe with its own after a number of start-ups (which is why I didn't post this myself). You'll know when it happens when it says "This game is not available". You should be able to repeat the steps in this tutorial to reapply the LAA fix when this happens, although Steam won't generate a new .exe file until the next time you start SMOD or any other mod using Source 2006.

EDIT: VVV Just start up SMOD again and it should generate a new .exe file.

I started SMOD again, and it didnt changed the .exe file. Well this is the second time I started it, I will keep checking in future.

EDIT: yes, OMS like always ur right! I started the mod for the 5th time and the .exe was changed! I did the fix again, takes less then a minute, but thanks for the advice!
« Last Edit: February 09, 2013, 09:20:28 PM by Counter-Life™ »

Offline Onemanshow

  • JuanMan
  • *
  • *
  • +67% chance to make useful post
  • Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #9 on: February 10, 2013, 02:20:52 AM »
EDIT: yes, OMS like always ur right! I started the mod for the 5th time and the .exe was changed! I did the fix again, takes less then a minute, but thanks for the advice!

I think I may have found a permanent fix for Steam replacing the .exe. Add this to the end of SMOD's commandline (right click-properties-set launch options):

Code: [Select]
-hushsteam

I've ran SMOD several times with this and Steam hasn't replaced the modified .exe file yet. Can you (or anyone else) see if this works on your end too?
« Last Edit: February 10, 2013, 02:35:42 AM by Onemanshow »

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #10 on: February 10, 2013, 08:38:16 AM »
EDIT: yes, OMS like always ur right! I started the mod for the 5th time and the .exe was changed! I did the fix again, takes less then a minute, but thanks for the advice!

I think I may have found a permanent fix for Steam replacing the .exe. Add this to the end of SMOD's commandline (right click-properties-set launch options):

Code: [Select]
-hushsteam

I've ran SMOD several times with this and Steam hasn't replaced the modified .exe file yet. Can you (or anyone else) see if this works on your end too?

This would be amazing! I will test this, and see if it works! Your still the best, OMS!

EDIT: Started SMOD with the patched .exe + the new command line 7 times in a row, never said anything about "game data not aviable" or something! Im sure this works(last time it gave me that error message at the 5th start)! I will edit the instructions.
« Last Edit: February 10, 2013, 08:46:43 AM by Counter-Life™ »

Offline BIZ

  • 32-Bit Hobo
  • *
  • *
  • +0% chance to make useful post
  • BIZ hides in shadows.
    • BSNOOCH.COM
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #11 on: February 10, 2013, 02:33:43 PM »
EDIT: yes, OMS like always ur right! I started the mod for the 5th time and the .exe was changed! I did the fix again, takes less then a minute, but thanks for the advice!

I think I may have found a permanent fix for Steam replacing the .exe. Add this to the end of SMOD's commandline (right click-properties-set launch options):

Code: [Select]
-hushsteam

I've ran SMOD several times with this and Steam hasn't replaced the modified .exe file yet. Can you (or anyone else) see if this works on your end too?

+rep

Offline Onemanshow

  • JuanMan
  • *
  • *
  • +67% chance to make useful post
  • Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #12 on: February 10, 2013, 06:01:40 PM »
Started SMOD with the patched .exe + the new command line 7 times in a row, never said anything about "game data not aviable" or something! Im sure this works(last time it gave me that error message at the 5th start)! I will edit the instructions.

;D


One more thing: I advise anyone who uses this tutorial to add -hushsteam to every mod that uses the Source 2006 Base (i.e all SMOD's, Underhell, CSS SCIFI, legacy HL2 mods). Otherwise Steam will replace the .exe when you run those mods. Might want to add this into the OP.

Offline Onemanshow

  • JuanMan
  • *
  • *
  • +67% chance to make useful post
  • Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!Onemanshow is awe-inspiring!
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #13 on: February 14, 2013, 07:07:47 PM »
Oh Valve. ::)

Looks like the recent Steam update broke the -hushsteam flag, but fixed my original way of stopping Steam's .exe check.

In your launch options, replace the "-hushsteam" flag with "-nolocalcopy". If Valve somehow breaks -nolocalcopy again in a future update, try switching it back to -hushsteam.


Counter-Life, I hope you don't mind that I edited the OP to reflect this new information.


EDIT: The recent client updates are doing strange things to both flags it seems. Best to throw both in the end of your launch options like so;

Code: [Select]
-nolocalcopy -hushsteam

Gonna edit the OP again.
« Last Edit: February 14, 2013, 07:34:19 PM by Onemanshow »

Offline Counter-Life™

  • *
  • *
  • +17% chance to make useful post
  • Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!Counter-Life™ is a rising star!
    • Youtube Channel
Re: [Tutorial] Make SMOD dosent crash so often/LAA
« Reply #14 on: February 14, 2013, 07:42:15 PM »
Oh Valve. ::)

Looks like the recent Steam update broke the -hushsteam flag, but fixed my original way of stopping Steam's .exe check.

In your launch options, replace the "-hushsteam" flag with "-nolocalcopy". If Valve somehow breaks -nolocalcopy again in a future update, try switching it back to -hushsteam.


Counter-Life, I hope you don't mind that I edited the OP to reflect this new information.


EDIT: The recent client updates are doing strange things to both flags it seems. Best to throw both in the end of your launch options like so;

Code: [Select]
-nolocalcopy -hushsteam

Gonna edit the OP again.

Thx for the info, its like VALVe tracks this topic and dosent want us to do this xD

EDIT: Added new launch options, closed Steam, fixed .exe again, opened Steam again and played, fix still seems to work for me so far. Lets hope they dont do anything that breaks this.
« Last Edit: February 14, 2013, 08:04:16 PM by Counter-Life™ »