Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: (I think I'm onto something) SMOD just shit itself  (Read 6874 times)

0 Members and 1 Guest are viewing this topic.

Offline Dez

  • *
  • +1% chance to make useful post
  • Dez has no influence.
Re: (I think I'm onto something) SMOD just shit itself
« Reply #30 on: November 26, 2013, 06:27:09 PM »
No problem man, glad you solved it.

Offline PaiCrai

  • *
  • +3% chance to make useful post
  • PaiCrai has no influence.
SMOD is done shitting itself but new problems have arrived (same thread)
« Reply #31 on: November 26, 2013, 06:35:21 PM »
No problem man, glad you solved it.
But apparently in the process I managed to screw up a few CS:S weapons...

1. The knife is standard skin and is broken as all fuck
2. The P90's Ironsights don't work and it's been turned into a crotchgun for the NPCs
3. The UZI's Ironsights are broken
4. The silenced USP is just a standard USP with a broken ironsights
smignature

Offline PaiCrai

  • *
  • +3% chance to make useful post
  • PaiCrai has no influence.
k i fixed it sry
« Reply #32 on: November 26, 2013, 07:05:54 PM »
yea
smignature

Offline Comrade

  • *
  • *
  • +11% chance to make useful post
  • Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...
Re: SMOD is done shitting itself but new problems have arrived (same thread)
« Reply #33 on: November 26, 2013, 07:08:05 PM »
No problem man, glad you solved it.
But apparently in the process I managed to screw up a few CS:S weapons...

1. The knife is standard skin and is broken as all fuck
2. The P90's Ironsights don't work and it's been turned into a crotchgun for the NPCs
3. The UZI's Ironsights are broken
4. The silenced USP is just a standard USP with a broken ironsights
*scratches head* That means that you've used custom skins that were not a part of SMOD, and had the same names as the default CSS skins. I think you need to find whatever custom skins you've used and install them on top of SMOD.
But come to think of it that doesn't make sense, in order for that to happen, you should have been brought up with that Replace dialog, but it looks like it never happened. You could have missed it, though.

Offline Dez

  • *
  • +1% chance to make useful post
  • Dez has no influence.
Re: (I think I'm onto something) SMOD just shit itself
« Reply #34 on: November 26, 2013, 07:10:25 PM »
I think I actually know the problem you're talking about, just out of curiosity, what SMOD: Tactical are you using? I'm using a  build I found on a youtube video claiming it was Delta 6, so my P90 ironsights are a little different from yours.

Post a picture of your P90 ironsights for me, this is what mine look like: http://i.imgur.com/nOhLPG2.jpg

I think I know what issue you're having, I had a problem with the knife earlier but I sorta overlooked it.

Remember what you did when you extracted models, materials and sounds from cstrike_pak_dir.vpk?  Go back and extract cfg, materials, models, particles, resource, scripts and sound, all of it except classes and maps (i guess you can extract those too if you want), and then re-install SMOD over it again. I didn't think of doing this earlier (sorry about that)

When I did that, the knife was back to it's default SMOD: T skin. My USP seems to be functioning normally, the P90 ironsights work and NPC's use them correctly, the only thing is that the UZI's ironsights don't have proper sight picture (untrue ironsights) but they're still accurate if you're using the front sight (it may have been intentional considering how small the UZI's rear iron-sight is)

Try that and tell me if it works.

Offline PaiCrai

  • *
  • +3% chance to make useful post
  • PaiCrai has no influence.
Re: (I think I'm onto something) SMOD just shit itself
« Reply #35 on: November 26, 2013, 07:50:10 PM »
I fixed it now, guys.

It appears it refused to overwrite the CS:S models even though it said so when I copied the SMOD files over, so I had to delete all the files of the faulty weapons and slap the SMOD files back in there and it worked perfectly. Although  the v_models and w_models looked the same except for the knife and usp, I don't know why they wouldn't function properly.

ALSO EDIT

I'm (allegedly) using Delta 6, and thanks for your super usefulness!
« Last Edit: November 26, 2013, 07:51:47 PM by PaiCrai »
smignature

Offline PaiCrai

  • *
  • +3% chance to make useful post
  • PaiCrai has no influence.
OH SHIT EVEN MORE ISSUES
« Reply #36 on: November 26, 2013, 08:17:09 PM »
I found a few effects/particles missing... For example the smoke in Gasworks is are checkerboards... Also at the firing range there's still one model labelled "ERROR"...
smignature

Offline Dez

  • *
  • +1% chance to make useful post
  • Dez has no influence.
Re: (I think I'm onto something) SMOD just shit itself
« Reply #37 on: November 26, 2013, 10:14:00 PM »
I didn't see any missing models in the firing range, but I remember that being an issue even before the steampipe update on SMOD: T build 5.56. I'm not sure what to tell you because I can't replicate the issue on my end, can you try and get me an impulse 106 on the missing model or something?

I looked into the gasworks particle problems and I noticed the missing textures by the smokestacks. I decompiled the map and the material it's trying to use is "materials/particle/particle_smokegrenade1", the basetexture of which is particle_smokegrenade_thick.vtf. The VMT is in the right place, though.

However I went into the log in-game and found this:
Error reading in file "materials/particle/particle_smokegrenade_thick.vtf"
Error reading in file "materials/particle/particle_sphere.vtf"


Which I'm %99.9 certain is what's causing the issue. I have no idea what that means or what's causing it though, I'll tinker around with it and see if I can get it to work. Maybe somebody else knows?
« Last Edit: November 26, 2013, 10:40:52 PM by Dez »

Offline Dez

  • *
  • +1% chance to make useful post
  • Dez has no influence.
Re: (I think I'm onto something) SMOD just shit itself
« Reply #38 on: November 26, 2013, 10:37:24 PM »
Wait, nevermind, I got it.

Turns out it was a problem that specifically had to do with those textures and not the mod itself (so it's not a massive issue but annoying for people playing gasworks nonetheless). I've remade and reuploaded a quickfix that I found on cspromod forums:

Download

(just drop the materials folder into your smodtactical folder and let it overwrite the files)
« Last Edit: November 26, 2013, 10:39:43 PM by Dez »