Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: [SOLVED] CSS SCI FI 3 Hardwired disconnecting problem  (Read 4112 times)

0 Members and 1 Guest are viewing this topic.

Offline Bomba1000

  • *
  • +1% chance to make useful post
  • Bomba1000 has no influence.
[SOLVED] CSS SCI FI 3 Hardwired disconnecting problem
« on: March 24, 2015, 09:09:22 AM »
When I'm trying to start de_ map, the map loads, but then crashes to the main menu with an error in the console:


] map de_cbble
execing game.cfg
Spawn Server de_cbble
Begin loading faces (loads materials)
End loading faces (loads materials)
*** load constant CSS SCI FI values.

execing skill.cfg
Please reload current map.
Attempted to create unknown entity type func_buyzone!
Can't init func_buyzone
Attempted to create unknown entity type func_bomb_target!
Can't init func_bomb_target
Attempted to create unknown entity type func_bomb_target!
Can't init func_bomb_target
Attempted to create unknown entity type func_buyzone!
Can't init func_buyzone
Precahing gib models

*** NODE LIST NOT FOUND. YOU MAY NEED TO REINSTALL THE MOD.***

Game started
No pure server whitelist. sv_pure = 0
CAsyncWavDataCache:  466 .wavs total 0 bytes, 0.00 % of capacity
Initializing renderer...
AddPropOffsetToMap - already found entry [prop: 295 offset: 3540] in table for DT_NPC_Manhack
Dropped unnamed from server (Disconnect by user.)
couldn't exec userconfig.cfg
Host_WriteConfiguration: Wrote cfg/config.cfg

« Last Edit: March 24, 2015, 12:02:32 PM by Bomba1000 »

Offline Comrade

  • *
  • *
  • +11% chance to make useful post
  • Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...
Re: CSS SCI FI 3 Hardwired disconnecting problem
« Reply #1 on: March 24, 2015, 11:54:52 AM »
ai_norebuildgraph 0 *may* help.

Offline Bomba1000

  • *
  • +1% chance to make useful post
  • Bomba1000 has no influence.
Re: CSS SCI FI 3 Hardwired disconnecting problem
« Reply #2 on: March 24, 2015, 12:01:16 PM »
ai_norebuildgraph 1 helped, thanks.

Offline Comrade

  • *
  • *
  • +11% chance to make useful post
  • Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...Comrade might someday be someone...
Re: CSS SCI FI 3 Hardwired disconnecting problem
« Reply #3 on: March 24, 2015, 02:03:19 PM »
ai_norebuildgraph 1 helped, thanks.

Going to be harmful in the long run.

Offline Rook

  • *
  • +2% chance to make useful post
  • Rook has no influence.
Re: [SOLVED] CSS SCI FI 3 Hardwired disconnecting problem
« Reply #4 on: March 25, 2015, 05:14:01 AM »
For what it's worth:

Oh, and by the way, been trying to run CSS SCI FI 3 HARDWIRED, getting a crash-to-main-menu after loading.

http://pastebin.com/7VKKMX2T

  • Enter disable_loadmapadd 1 in the console.
  • Enter map de_dust2 in the console and load the map.
  • Stand by as a dummy nodegraph is built.
  • disable_loadmapadd 0
  • Enjoy.

CSS SCI FI attempts to avoid a crash straight to desktop from operations done on a bad or missing node list. Unfortunately, this check results in a false positive when the game reads the map's .ain as outdated and attempts to generate a new one.

The above skips loading the mapadd system altogether, which lets the game create a new dummy .ain without interference from the script's node check. It's an annoying error, but it definitely beats a crash to desktop with no error at all.
« Last Edit: March 25, 2015, 05:19:05 AM by Rook »