Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: subviewcam issue  (Read 2938 times)

0 Members and 1 Guest are viewing this topic.

Offline Doritosman

  • *
  • +1% chance to make useful post
  • Doritosman has no influence.
subviewcam issue
« on: August 04, 2011, 03:53:31 AM »
I was trying out the subviewcam feature of smod and I almost got it working correctly. However, the scope doesn't seem to show what's actually behind it. Here's a few screenies:

nonironsighted. I'm pointing at a brick wall yet the cam shows grass. (my crosshair's pretty faint)
http://steamcommunity.com/id/leadpancakes/screenshot/578930397336720678

ironsighted. Same issue
http://steamcommunity.com/id/leadpancakes/screenshot/578930397336718723

I've looked at the G36C from smod tactical and I found out the default and smod:t's cam fov is different. I've tried out a few numbers but none of them can correct the problem. I messed around with the "size" variable, but that also doesn't work.

Would appreciate it if anyone here can give me any pointers on how to fix this :)

Offline 0per4t0r

  • *
  • +1% chance to make useful post
  • 0per4t0r has no influence.
    • My Youtube
Re: subviewcam issue
« Reply #1 on: August 04, 2011, 05:36:54 AM »
Try a size of 512 and a FOV of .05, that's what Tactical's AWP uses for its RT scope.

From snip_awp\scope_rt.vmt:
Code: [Select]
"SubViewCam" {
"ReplaceTexture" "$basetexture"
"OverlayTexture" "models\weapons\v_models\snip_awp\glare"
"DefaultAlpha" "1"
"SightedAlpha" ".1"
"BufferID" "0"
"Size" "512"
"FOV" ".05"
"Filter2" "shader/vm_cafilter"

Offline Doritosman

  • *
  • +1% chance to make useful post
  • Doritosman has no influence.
Re: subviewcam issue
« Reply #2 on: August 04, 2011, 08:44:46 PM »
Tried those settings and it still didn't work. Guess I'll just use the classic scopes if I can't figure this out.

Offline 0per4t0r

  • *
  • +1% chance to make useful post
  • 0per4t0r has no influence.
    • My Youtube
Re: subviewcam issue
« Reply #3 on: August 04, 2011, 09:17:23 PM »
Hmm...
Along with scope_rt.vmt, I found this in scope.vmt:

Code: [Select]
"SubViewCam" {
"ReplaceTexture" "$basetexture"
"OverlayTexture" "models\weapons\v_smg1\overlay"
"DefaultAlpha" "1"
"SightedAlpha" "1"
"BufferID" "0"
"FOV" "1"
// "Filter1" "shader/vm_lens"
// "Filter2" "shader/vm_cafilter"