Welcome, Guest. Please login or register. Did you miss your activation email?

Author Topic: AppHangB1!? Really?  (Read 2460 times)

0 Members and 1 Guest are viewing this topic.

Offline Troggy Hordesman

  • *
  • +3% chance to make useful post
  • Troggy Hordesman has no influence.
AppHangB1!? Really?
« on: March 25, 2013, 02:27:37 PM »
Okay, so I have had problems starting map d1_town_01a and the reasons I found out were in "AppHangB1" which is really strange since AppHangB1 is known to either prevent a game from starting alltogether, or be completely random. In this case, however, it only appears on one single map (d1_town_01a) and crashes it before loading completely.

Anyone knows what is going on here? Does this really have anything to do with my computer overall, because this is the only place in any game were this happens.
My behind is behind me, always watching.

Offline Troggy Hordesman

  • *
  • +3% chance to make useful post
  • Troggy Hordesman has no influence.
Re: AppHangB1!? Really?
« Reply #1 on: March 27, 2013, 06:44:55 AM »
Okay, I fixed the problem, and get this: what you need to do is removing the mapadd for the previous map. Makes sense? None whatsoever. This problem did not exist a week ago, so it's just Source being a douche.

(・ェ・`)
« Last Edit: March 27, 2013, 10:26:03 AM by Troggy Hordesman »
My behind is behind me, always watching.

Offline IronCore

  • *
  • +3% chance to make useful post
  • IronCore has no influence.
Re: AppHangB1!? Really?
« Reply #2 on: March 28, 2013, 12:41:02 AM »
yeah sometimes complex mapadds especially if there's too many entities being created sometimes do crashes the game or won't run the map at all.
I'm so in-love to SMOD...PERIOD!

Offline Troggy Hordesman

  • *
  • +3% chance to make useful post
  • Troggy Hordesman has no influence.
Re: AppHangB1!? Really?
« Reply #3 on: March 28, 2013, 06:28:10 AM »
But it doesn't quite make any sense as these mapadd scripts were untouched since last time I modded the game. Even by lowering the amount of enemies or even removing the extra spawns in the script completely made the crashes occur, something it didn't last time. It seems that the mod (or more likely the souce engine) just decided to screw with me suddenly in areas of the game that worked a week prior.

I am taking a break from smod as a result, it seems like it is creating errors out of the blue just to have me water down the mod to nothing.
My behind is behind me, always watching.

Offline JoshZemlinsky

  • *
  • +2% chance to make useful post
  • JoshZemlinsky has no influence.
Re: AppHangB1!? Really?
« Reply #4 on: March 28, 2013, 10:02:57 AM »
You too?
Damn. i've also begun getting weird crashes in Smod... Tho i sorta traced my problem to a few guns that would crash the game if not precached on map load.
How it suddenly changed 1 day to another is really weird.

Offline IronCore

  • *
  • +3% chance to make useful post
  • IronCore has no influence.
Re: AppHangB1!? Really?
« Reply #5 on: March 28, 2013, 10:26:30 AM »
probably another pesky sneaky update went by for hl2 engine unnoticed reason for your sudden crashes, you gotta love valve and steam LoL!
I'm so in-love to SMOD...PERIOD!

Offline Troggy Hordesman

  • *
  • +3% chance to make useful post
  • Troggy Hordesman has no influence.
Re: AppHangB1!? Really?
« Reply #6 on: March 29, 2013, 04:37:04 AM »
I should note that the "save/restore overflow" error that I have had lately and this is one of the same. However, I will continue this here rather than the other thread for clarity.

Upon having the "save/restore overflow", the game will create files in the save folder named after the map where the error occured of the file formats .hl1, .hl2 and .hl3. The .hl1 format ranges in size between 1-2mb, while .hl2 around 100-300kb and hl3 is always 1kb.
My behind is behind me, always watching.

Offline Troggy Hordesman

  • *
  • +3% chance to make useful post
  • Troggy Hordesman has no influence.
Re: AppHangB1!? Really?
« Reply #7 on: April 06, 2013, 07:04:44 AM »
I finally fixed it. Appears that Ravenholm is allergic to increased ragdolls, so if anyone wants to run a mod with Ravenholm avoid increased ragdoll limit or setting ignore_ragdollmanager to 1. This does not explain why it worked a week before this happened initially, but atleast it is fine now.

EDIT: I am sorry for the double posts, but I thought it was necessary as an update.
My behind is behind me, always watching.